Got a question that the wiki doesn't answer? Ask on the forum (preferred), or join us on IRC.

BeastNode

CommandHelper/Staged/Compatibility

From EngineHub.org Wiki
Jump to: navigation, search


This page lists compatibility of various milestone versions of CommandHelper. Note that this chart was created starting with build 1498, so earlier builds may not be accurate. In general, the compatibility requirements, if not listed, are the same as the previous milestone build. The minimum requirements for the current builds are:

  • Java 7
  • Bukkit version as specified below (when used as a Bukkit plugin)

Also note that CommandHelper may still be backwards and forward compatible to a large degree, many of the advanced features that normally have hard dependencies on certain versions of external dependencies have been configured to "soft" fail, that is, individual components may not work, but in general the plugin should continue to function. Regardless, only the most current dev builds are officially supported.

Build # Source Milestone Compatibility
#2895- 6304f91 Should still be compatible with former build Spigot 1.8.6
#2857- f8953eb Removed WorldEdit dependency (See SKCompat extension)
#2842- 4b485fd Removed vault dependency (See CHVault extension)
#2802- cc0f80e Updated to Spigot 1.8.
  • Vault 1.4
Spigot 1.8
#2717-aca997c aca997c Updated several dependencies:
  • jsch: 0.1.51
  • WorldEdit: 5.6.2
  • WorldGuard 5.9
  • commons-codec: 1.9
  • activation: 1.1.1
  • mail: 1.5.0-b01
  • mysql-connector-java 5.1.30
  • jedis: 2.5.1
#2716-512d9d3 484c064 Updated to Minecraft 1.7.9 (should still be compatible with 1.7.2 builds, excepting that Sound.BREATH and Sound.HURT have been removed). Bukkit 1.7.9
#2681-773d877 773d877 Updated to Minecraft 1.7.8 (should still be compatible with 1.7.2 builds, however) Bukkit 1.7.8
#2445-8c4b165 8c4b165 Updated to Minecraft 1.7.2 Bukkit 1.7.2
1561 896165c Updated to Minecraft 1.6 Bukkit 1.6.1
1556 c14f67a Updated third party dependencies
  • commons-codec: 1.8
  • mysql-connector-java: 5.1.25
  • sqlite-jdbc: 3.7.15-M1
  • snakeyaml: 1.12

Testing only:

  • powermock: 1.5.1
1502 cda686f Updated bukkit (Many other deps were updated at this time as well)
  • Bukkit: 1.5.2
  • WorldEdit: 5.5.6
  • WorldGuard: 5.7.3
  • json-simple: 1.1.1
  • log4j: 1.2.17
  • jsch: 0.1.50

Testing only:

  • junit: 4.11
  • mockito-core: 1.9.5
  • powermock-module-junit4: 1.5
  • powermock-api-mockito: 1.5
1498 765e75f First tracked compatibility Bukkit: 1.5.1
1425 279381f Added optional redis dependency Redis 2.6.13
??? 1.4.7 Backport Backport of the latest build of CH, backported to be compatible with 1.4.7. Not officially supported, community maintained. Bukkit: 1.4.7
1337 fd35d2e Updated to bukkit 1.4.7 Bukkit: 1.4.7
0123756 Updated to bukkit 1.4.6 Bukkit: 1.4.6

Navigation menu